API version: unstable
API version: 2021-04 Release candidate
API version: 2021-01 Latest
API version: 2020-10
API version: 2020-07
API version: 2020-04
API version: 2020-01 Unsupported
API version: 2019-10 Unsupported

SubscriptionAppliedCodeDiscount object

Version unstable

Represents an applied code discount.

Required access

Requires either all_subscription_contracts or own_subscription_contracts scope.

On this page

Fields

  • id (ID!)

    The unique identifier.

  • redeemCode (String!)

    The redeem code of the discount that applies on the subscription.

  • The reason that the discount on the subscription draft is rejected.

Version 2021-04 (Release candidate)

Represents an applied code discount.

Required access

Requires either all_subscription_contracts or own_subscription_contracts scope.

On this page

Fields

  • id (ID!)

    The unique identifier.

  • redeemCode (String!)

    The redeem code of the discount that applies on the subscription.

  • The reason that the discount on the subscription draft is rejected.

Version 2021-01 (Latest)

Represents an applied code discount.

Required access

Requires either all_subscription_contracts or own_subscription_contracts scope.

On this page

Fields

  • id (ID!)

    The unique identifier.

  • redeemCode (String!)

    The redeem code of the discount that applies on the subscription.

  • The reason that the discount on the subscription draft is rejected.