API version: unstable
API version: 2021-04 Release candidate
API version: 2021-01 Latest
API version: 2020-10
API version: 2020-07
API version: 2020-04
API version: 2020-01 Unsupported
API version: 2019-10 Unsupported

paymentsAppConfigure mutation

Version unstable

Configure the partner managed gateway onto the merchant's store.

Required access

write_payment_gateways access scope.

Interactive example

This is an example mutation query. Use the embedded interactive tool below to edit the query.

Hint: use Ctrl + Space for autocompleting fields.


Arguments

Argument Description
externalHandle ( String )

Handle used in the external system.

ready ( Boolean! ) required

The provider is ready to process merchant's payments.

Return fields

Version 2021-04 (Release candidate)

Configure the partner managed gateway onto the merchant's store.

Required access

write_payment_gateways access scope.

Interactive example

This is an example mutation query. Use the embedded interactive tool below to edit the query.

Hint: use Ctrl + Space for autocompleting fields.


Arguments

Argument Description
externalHandle ( String )

Handle used in the external system.

ready ( Boolean! ) required

The provider is ready to process merchant's payments.

Return fields

Version 2021-01 (Latest)

Configure the partner managed gateway onto the merchant's store.

Required access

write_payment_gateways access scope.

Interactive example

This is an example mutation query. Use the embedded interactive tool below to edit the query.

Hint: use Ctrl + Space for autocompleting fields.


Arguments

Argument Description
externalHandle ( String )

Handle used in the external system.

ready ( Boolean! ) required

The provider is ready to process merchant's payments.

Return fields